Icom IC-9700 users topic

Transceiver mods, fixes, issues, reviews
VK1JA
Forum Diehard
Posts: 351
Joined: Tue Sep 14, 2010 9:50 pm

Re: Icom IC-9700 users topic

Post by VK1JA » Fri Apr 19, 2019 6:21 pm

My first impressions is that the 9700 seems to be more sensitive and selective compared to the ts2000 with transverter for 23cm.

This afternoon I was hearing the 2m geelong and gippsland beacons (with no apparent troppo conditions) when I'd normally wouldn't hear them in the afternoons on the ts2000. I was also seeing the sydney 2m on spec lab when I would only ever see it via aircraft enhancement on the ts2000.

I'm also seeing the 23cm nimatebell beacon without a masthead lna, which I couldn't do on the ts2000 (with transverter for 23cm).

I've still got to fine tune the spectrum display as it's still a bit vague and using spec lab on the pc still shows the very weak (not audible) beacons, when the display on the 9700 shows no trace.

I did a quick tx test on 2m wspr, drift on first tx is bad and drifts bad enough to not decode. Second tx (straight after first) will decode with 3-4Hz drift. The next rx, as it cools has the rx drifting bad enought to not decode. TX power was 10w.

VK2XAX
Forum Diehard
Posts: 259
Joined: Tue Jul 10, 2007 11:05 am
Location: Penrith, NSW
Contact:

Re: Icom IC-9700 users topic

Post by VK2XAX » Sat Apr 20, 2019 10:05 am

VK4GHZ wrote:
VK2XAX wrote:Adam will have to resurrect his Mutli-send kit for this radio too.

No PTT per band on any of its ACC sockets either !
I'm well ahead of the curve!
Started developing a solution back over 12 months ago, known as the SEQ-9700.
Awesome!

One question.... will it be backward compatible with the IC-910 ?

If so, I'll have one now :) for my trusty old 910 and wait until the 9700 gets its issues fixed before out laying the $

thanks

Tim
--

VK2XAX :: QF56if23 :: BMARC :: WIA :: AMSAT-VK

User avatar
VK4GHZ
Forum Diehard
Posts: 1846
Joined: Mon Jul 04, 2011 10:39 pm
Contact:

Re: Icom IC-9700 users topic

Post by VK4GHZ » Sat Apr 20, 2019 10:29 am

VK2XAX wrote:One question.... will it be backward compatible with the IC-910 ?

If so, I'll have one now :) for my trusty old 910 and wait until the 9700 gets its issues fixed before out laying the $
Unfortunately no Tim.

The 910 Multi-Send used a combined analogue voltage to sense which band was the main TX band.
This voltage was applied to an ADC input of a MCU, and switched the appropriate relay with delays.
Analogue voltage sense was used because the 910's CI-V command set was fairly primitive.

The IC-9700 has a more comprehensive CI-V command set, so the SEQ-9700 uses CI-V data.
I'm not interested in voiding my warranty with mods, just yet.

Needles to say, a 910 Multi-Send would work with a modified IC-9700. :shh:

All you need to do is provide the Multi-Send analogue input with the following volts:

• 23cm: 0 V (so it was compatible with a 910 without 23cm option)
• 70cm: 1.8 - 2.0 V
• 2m: 4.2 - 4.5 V
Adam, Brisbane
http://vk4ghz.com | VK4GHZ on Youtube
Image Waiting for the perfect 2/70/23 multi-mode SDR transceiver

User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

Re: Icom IC-9700 users topic

Post by VK3ZAZ » Sat Apr 20, 2019 10:39 am

Changes from Version 1.05
•Improved accuracy of the automatic reference frequency calibration.
•Fixed unintended indication on the DR screen.
•Eliminated RX audio gap when changing the IF filter in the DV mode.

To update the firmware
•Thoroughly read 13. UPDATING THE FIRMWARE of the ADVANCED MANUAL and follow the instructions displayed on the IC-9700 LCD screen.
•Making a backup file of programmed contents and settings onto the SD card before updating the firmware is recommended.
•The firmware will be updated to the following versions.
Main CPU: 1.06
Sub CPU: 1.00
Front CPU: 1.00
FPGA Program: 1.03
FPGA Data: 1.00
DV DSP: 1.02

All done using SAN DISC SD CARD
Last edited by VK3ZAZ on Sun Apr 21, 2019 8:24 am, edited 1 time in total.
Tread your own path :om:

User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

Re: Icom IC-9700 users topic

Post by VK3ZAZ » Sun Apr 21, 2019 8:21 am

PREAMPS
You can have
External mast-head ON
and
Internal On
or
Internal OFF
or ATT ON.
You can have Mast-head EXT ON
and
ATT ON
You can have mast-head OFF
and
INTERNAL ON
If masthead is on and system senses a short cct it is turned off by the radio

Also an RFG warning tells you iff its not TOP DEAD CENTRE MAx gain.

Power overshoot fixed by setting TX delay as per handbook in menu.

QED
Tread your own path :om:

User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

Firmware upgrade

Post by VK3ZAZ » Sun Apr 21, 2019 10:20 am

Attempted firmware upgrade via sd card but is says NO FILE
Tried formatting it in radio
But this didn't seem to work as when I checked it in PC files still evident
so did full slow format and down loaded firmware file.
unzipped firmware onto SD card
made sure that DAT file was in the root directory as well as in the folder
but radio wont find the file?

Any ideas brains trust?
Tread your own path :om:

VK1JA
Forum Diehard
Posts: 351
Joined: Tue Sep 14, 2010 9:50 pm

Re: Icom IC-9700 users topic

Post by VK1JA » Sun Apr 21, 2019 10:26 am

Make sure the .dat file is sitting in the IC9700 directory, not the root directory.

User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

Re: Icom IC-9700 users topic

Post by VK3ZAZ » Sun Apr 21, 2019 4:51 pm

Did that no joy


anyone know a closer source of SF-IC7300 Screen protectors for displays - Icom IC9700 instead of Europe and $15 plus post?

WSPR works fine not too much drift on receive Interesting diversity 910H OCXO is better than 9700
cant figure out how to make it transmit.. guess gotta buy the $200 software package
Beams at VK5
2019-04-21 07:22 VK5GF 144.490553 -12 0 PF94hk +40 10.000 VK3ZAZ QF12ag 388 241
2019-04-21 07:22 VK5GF 144.490540 -16 0 PF94hk +40 10.000 VK3OT QF12ag 388 241
2019-04-21 07:00 VK5GF 144.490553 -6 0 PF94hk +40 10.000 VK3ZAZ QF12ag 388 241
2019-04-21 07:00 VK5GF 144.490538 -8 0 PF94hk +40 10.000 VK3OT QF12ag 388 241
2019-04-21 06:40 VK5GF 144.490552 -5 0 PF94hk +40 10.000 VK3ZAZ QF12ag 388 241 910H
2019-04-21 06:40 VK5GF 144.490537 -5 0 PF94hk +40 10.000 VK3OT QF12ag 388 241 9700




73
Tread your own path :om:

User avatar
VK3BA
Forum Diehard
Posts: 325
Joined: Fri Mar 28, 2008 8:27 am
Location: QF21BW Bannockburn
Contact:

Re: Firmware upgrade

Post by VK3BA » Mon Apr 22, 2019 5:43 pm

VK3ZAZ wrote:Attempted firmware upgrade via sd card but is says NO FILE
Tried formatting it in radio
But this didn't seem to work as when I checked it in PC files still evident
so did full slow format and down loaded firmware file.
unzipped firmware onto SD card
made sure that DAT file was in the root directory as well as in the folder
but radio wont find the file?

Any ideas brains trust?
G'day Steve,

What size of SD card are you using? I initially tried a SanDisk Extreme 64GB and the rig wouldn't read or format it. Then went down to Woolies and grabbed a Lexar Pro 32GB SD card and the rig will read, format and write no worries at all. Recently found the same with the IC-7300.

Upon finally reading the manual late this arvo, it turns out at the start of section 6 in the manwel that the maximum acceptable size is 32GB... :oops:

I haven't yet tried the CS-9700 but I suspect this might be part of your problem. Thought I'd try using both these rigs without RTFM... :crazy:

The use of repeaters on the IC-7300 & IC-9700 isn't as easy as the IC-910H's, nor is it very well explained in the manual. Learning curve... :om:

Let us know how you go. I'll fire up the other non-work confuser, download the CS-9700, do a transfer and let you know maybe later on tonight.

Cheers,
Nik VK3BA
Bannockburn
http://www.qrz.com/db/VK3BA

User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

WARNING TX LOCKUP

Post by VK3ZAZ » Tue Apr 23, 2019 9:35 am

Thanks will do.
Anyway went to call on morning rush and no mike audio.

Whilst stuffing around trying to get the radio to talk to WSJT-X using the IC-7300 settings and the guess and tries from facebook
I must have switched MIKE OFF so I decided to use my CS-9000 program
to look at what settings I needed to switch mike back on as I had set up CIV and CAT as prior to last night could only get WSJT-X going using RIG NONE and RTS for PTT.
WSPR worked fine on PC PTT using USB so what could go wrong?

Set radio up on 430 MHZ FM and tuned in on my 910H and activated CS-9000 software to see what settings I needed to change then CLUNK
BIG CARRIER on 430 MHZ FM and my TX light was on.
WTF>
Closed down CS-9000 tx still on.
Turned power down and waited and waited and waited and finally TX timer turned off tx at Ten minutes


Do not know, I have saved copy of the settings which I could share but they are an essay long.

Only way to get mike working was FULL RESET from which I lost all my settings but lucky I had day oen setup so got back the couple hundred memory entries and of course LOST DATA

Early days guys LOL


DUH

:?: :?:
Tread your own path :om:

VK7MO
Forum Novice
Posts: 14
Joined: Sat Sep 16, 2006 5:57 am

Re: Icom IC-9700 users topic

Post by VK7MO » Tue Apr 23, 2019 5:59 pm

Hi All

I have conducted some initial tests on a replacement IC-9700 and the results are essentially the same - that is about 20 Hz drift in a one minute transmission at 20 watts on 2 metres.

See attached Spectrum Lab plot.

73 Rex VK7MO
Attachments
Drift on New Radio Annotated.png

User avatar
VK3BA
Forum Diehard
Posts: 325
Joined: Fri Mar 28, 2008 8:27 am
Location: QF21BW Bannockburn
Contact:

Re: Icom IC-9700 users topic

Post by VK3BA » Wed Apr 24, 2019 5:10 pm

G'day Steve,

Re your SD card saga... I've copied a basic image from the rig to the SD card, downloaded CS-9700 from Icom JA, installed on a PC, inserted the SD card into PC, loaded the basic image, added heaps of memories & settings, saved to SD card, inserted SD card back into rig, loaded new file from SD in the menu, answered YES when required, restarted rig and good as gold. I'm using Lexar Pro Extreme SDXC 16GB cards in both rigs.

Cheers,
Nik VK3BA
Bannockburn
http://www.qrz.com/db/VK3BA

User avatar
VK3BA
Forum Diehard
Posts: 325
Joined: Fri Mar 28, 2008 8:27 am
Location: QF21BW Bannockburn
Contact:

Re: Icom IC-9700 users topic

Post by VK3BA » Wed Apr 24, 2019 6:44 pm

VK1JA wrote:Firmware 1.06 update is now available on the Icom Japan site:

http://www.icom.co.jp/support/download/ ... rmDwn2.php

Improvements include;
Improved accuracy of the reference frequency automatic adjustment function-
Fixed a defect on the DR screen display-
Eliminated an interruption in the reception sound that occurs when switching the IF filter in DV mode
-Other minor corrections.
It would be nice if a future firmware version has more of a choice for the screensaver timer... 60min is a bit short... increments up to about 12 hours would be a nice addition.

Cheers,
Nik VK3BA
Bannockburn
http://www.qrz.com/db/VK3BA

VK1JA
Forum Diehard
Posts: 351
Joined: Tue Sep 14, 2010 9:50 pm

Re: Icom IC-9700 users topic

Post by VK1JA » Thu Apr 25, 2019 7:29 am

SatPC32 Settings.

For those that like to play sat's, the port and config setting for the IC-9700 to work with SatPC32 are different to those needed to run WSJT-X. Probably due to the fact that SatPC32 and WSJT-x don't currently have official support for the IC-9700, rather you need to fool WSJT-X into thinking that you have a IC-7300, and a IC-9100 for SatPC32. I'm sure this will change once official support comes out, in the meantime these are the settings to get SatPC32 to control the IC-9700.

In SatPC32 > Setup > Radio Setup
Model > IC-9100
Baudrate > 19200
Addresses > $A2 $A2 (use the up/down arrows to change the Addresses, then press the 'Addresses OK' button
Com-Port > The Com-Port that your IC-9700 is set to on your PC
CAT Delay > 70
Put a tick in the 'Satelite Mode' box. Every other box is unchecked
Changing some of these settings will need a re-start of SatPC32 before you can change other settings - be patient, I had to restart SatPC32 about 4 times!

VK1JA
Forum Diehard
Posts: 351
Joined: Tue Sep 14, 2010 9:50 pm

Re: Icom IC-9700 users topic

Post by VK1JA » Thu Apr 25, 2019 7:32 am

Then on the radio..

On the IC-9700
Menu > Set > Connectors > CI-V
CI-V Baud Rate > 19200
CI-V Address > A2h
CI-V Transceive > ON
USB/LAN-REMOTE Transceive Address > 00h
CI-V USB Port > Unlink from [REMOTE]
CI-V USB Baud Rate > 19200
CI-V USB Echo Back > ON
CI-V Data Baud Rate > 9600
CI-V DATA Echo Back > OFF

You also need to put the IC-9700 into Satellite mode when you're ready to let SatPC32 control the rig - Menu > Satellite.

Don't forget to ensure the 'C-' on SatPC32 is selected to 'C+' !

Only a few of the radio settings needed to be changed to get it working, but I've listed all the CI-V settings just in case someone really balls' it up!

The bugga is that these settings won't work with WSJT-X, but you can save your WSJT-X settings as a backup (call it WSJT-X!) and save the SatPC32 settings (call it SatPC32) and you can easily switch between the two.

:beer:

VK7HH
Forum Diehard
Posts: 400
Joined: Thu Sep 08, 2005 11:18 pm
Location: Southern Tasmania
Contact:

Re: Icom IC-9700 users topic

Post by VK7HH » Thu Apr 25, 2019 11:12 am

Tests on frequency stability by Rex VK7MO


User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

Re: Icom IC-9700 users topic

Post by VK3ZAZ » Thu Apr 25, 2019 2:14 pm

VK3BA wrote:G'day Steve,

Re your SD card saga... I've copied a basic image from the rig to the SD card, downloaded CS-9700 from Icom JA, installed on a PC, inserted the SD card into PC, loaded the basic image, added heaps of memories & settings, saved to SD card, inserted SD card back into rig, loaded new file from SD in the menu, answered YES when required, restarted rig and good as gold. I'm using Lexar Pro Extreme SDXC 16GB cards in both rigs.

Cheers,
got upgrade in

wspr still sux even at 1% power lol
Tread your own path :om:

User avatar
VK3ZAZ
Forum Diehard
Posts: 802
Joined: Sat Dec 18, 2010 1:46 pm
Location: Hamilton Victoria Australia

Re: Icom IC-9700 users topic

Post by VK3ZAZ » Thu Apr 25, 2019 2:18 pm

I'm well ahead of the curve!
Started developing a solution back over 12 months ago, known as the SEQ-9700.[/quote]

Awesome!

One question.... will it be backward compatible with the IC-910 ?

If so, I'll have one now :) for my trusty old 910 and wait until the 9700 gets its issues fixed before out laying the $

thanks

Tim[/quote]

Ran PTT leads from THP amps to DIN plug
Two diodes isolating.
Can have both amps on and just select activate
works fine
TX delay set to 30%
Attenutators set to 50W
both amps making their power levels now.

PTT line is pin 3. Accessories.
Tread your own path :om:

VK3QI
Forum Diehard
Posts: 505
Joined: Wed Dec 02, 2009 9:17 pm

Re: Icom IC-9700 users topic

Post by VK3QI » Thu Apr 25, 2019 3:01 pm

Steve,

The only problem with that PTT solution is if you forget to de-activate the amp which is not required.

Adam's proposed solution is far more elegant and hopefully can be made to work on the IC9700.

Of course Icom could have solved this problem years ago if they had been prepared to change from only one PTT out to separate PTTs on each band (as has been done in the Kenwood TS2000X for the last 20 years!)

Cheers

Peter VK3QI

User avatar
VK3ALB
Forum Diehard
Posts: 1241
Joined: Sat Dec 22, 2007 3:56 am
Location: Geelong

Re: Icom IC-9700 users topic

Post by VK3ALB » Fri Apr 26, 2019 7:49 am

Has anyone looked for the TCXO in the 9700? I wonder if it's possible to put a bit of foam or other insulating material over/around it to minimise the influence of the fan.
Lou - VK3ALB

I'll decide how I enjoy my hobby.

Post Reply